import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^>]+?)([^>]*?)>(.*?)<\\/\\1>";
final String string = "^(?=.*?\\bdog\\b)((?!cat).)*$\n"
+ "<([^>]+?)([^>]*?)>(.*?)<\\/\\1>\n"
+ "This is the second paragraph. It contains an ordered list: \n"
+ "<ol>\n"
+ " <li>Item 1</li>\n"
+ " <li>Item 2</li>\n"
+ " <li>Item 3</li>\n"
+ " </ol>\n"
+ " This is a text after the list in the second paragraph.\n"
+ " This is another part of a paragraph\n"
+ " <ol>\n"
+ " <li>Item 1</li>\n"
+ " <li>Item 2</li>\n"
+ " <li>Item 3</li>\n"
+ " </ol>\n"
+ " This is a text after the another list in the second paragraph.\n"
+ "This is a text after the list in the second paragraph.\n"
+ " This is another part of a paragraph\n"
+ " <ol>\n"
+ " <li>Item 1</li>\n"
+ " <li>Item 2</li>\n"
+ " <li>Item 3</li>\n"
+ " </ol>\n"
+ "test to odfjdf iofsdfsoh\n";
final String subst = "\\1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}