#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^r\d{2,3}$"
Local $sString = "r00" & @CRLF & _
"r01" & @CRLF & _
"r12" & @CRLF & _
"r123" & @CRLF & _
"r999" & @CRLF & _
"r2222" & @CRLF & _
"5" & @CRLF & _
"15" & @CRLF & _
"354" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")