package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^r\d{2,3}$`)
var str = `r00
r01
r12
r123
r999
r2222
5
15
354
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}