$re = '~^r\d{2,3}$~m';
$str = 'r00
r01
r12
r123
r999
r2222
5
15
354
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);