using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^r\d{2,3}$";
string input = @"r00
r01
r12
r123
r999
r2222
5
15
354
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}