using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""product"": "")(.*?)(?="")";
string input = @"{""product"": ""product1""},{""product"": ""product2""},{""product"": ""product3""}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}