$re = '/(?<="product": ")(.*?)(?=")/';
$str = '{"product": "product1"},{"product": "product2"},{"product": "product3"}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);