#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^xX].*"
Local $sString = "123" & @CRLF & _
"run" & @CRLF & _
"fly" & @CRLF & _
"ssssdfaffasfdaaa" & @CRLF & _
"trifle" & @CRLF & _
"342gghj3frehjkg" & @CRLF & _
"x" & @CRLF & _
"X"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")