$re = '/[^xX].*/m';
$str = '123
run
fly
ssssdfaffasfdaaa
trifle
342gghj3frehjkg
x
X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);