package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^xX].*`)
var str = `123
run
fly
ssssdfaffasfdaaa
trifle
342gghj3frehjkg
x
X`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}