import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^xX].*";
final String string = "123\n"
+ "run\n"
+ "fly\n"
+ "ssssdfaffasfdaaa\n"
+ "trifle\n"
+ "342gghj3frehjkg\n"
+ "x\n"
+ "X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}