#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=_)\d+(?=_)"
Local $sString = "ddw_0_op1" & @CRLF & _
"ddw_1_op1" & @CRLF & _
"ddw_2_op1" & @CRLF & _
"ddw_3_op1" & @CRLF & _
"ddw_4_op1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")