using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=_)\d+(?=_)";
string input = @"ddw_0_op1
ddw_1_op1
ddw_2_op1
ddw_3_op1
ddw_4_op1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}