$re = '/(?<=_)\d+(?=_)/';
$str = 'ddw_0_op1
ddw_1_op1
ddw_2_op1
ddw_3_op1
ddw_4_op1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);