const regex = /(?<=_)\d+(?=_)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=_)\\d+(?=_)', 'g')
const str = `ddw_0_op1
ddw_1_op1
ddw_2_op1
ddw_3_op1
ddw_4_op1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}