#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*((de)|(dk)|(no)|(jp))_2015.+"
Local $sString = "2" & @CRLF & _
"" & @CRLF & _
"viatormobileprd_2015-12-05.tar.gz" & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"viatorpartnerprd_2015-12-05.tar.gz" & @CRLF & _
"viatormpartnerprd_2015-12-05.tar.gz" & @CRLF & _
"viatorcomse_2015-12-05.tar.gz" & @CRLF & _
"viatormse_2015-12-05.tar.gz" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4" & @CRLF & _
"viatorcomfr_2015-12-05.tar.gz" & @CRLF & _
"viatormfr_2015-12-05.tar.gz" & @CRLF & _
"viatorcomit_2015-12-05.tar.gz" & @CRLF & _
"viatormit_2015-12-05.tar.gz" & @CRLF & _
"viatorcomnl_2015-12-05.tar.gz" & @CRLF & _
"viatormnl_2015-12-05.tar.gz" & @CRLF & _
"" & @CRLF & _
"5" & @CRLF & _
"viatorcomes_2015-12-05.tar.gz" & @CRLF & _
"viatormes_2015-12-05.tar.gz" & @CRLF & _
"viatorcombr_2015-12-05.tar.gz" & @CRLF & _
"viatormbr_2015-12-05.tar.gz" & @CRLF & _
"" & @CRLF & _
"6" & @CRLF & _
"viatorcomde_2015-12-05.tar.gz" & @CRLF & _
"viatormde_2015-12-05.tar.gz" & @CRLF & _
"viatorcomdk_2015-12-05.tar.gz" & @CRLF & _
"viatorcomno_2015-12-05.tar.gz" & @CRLF & _
"viatorcomjp_2015-12-05.tar.gz" & @CRLF & _
"viatormjp_2015-12-05.tar.gz" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")