// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*((de)|(dk)|(no)|(jp))_2015.+").unwrap();
let string = "2
viatormobileprd_2015-12-05.tar.gz
3
viatorpartnerprd_2015-12-05.tar.gz
viatormpartnerprd_2015-12-05.tar.gz
viatorcomse_2015-12-05.tar.gz
viatormse_2015-12-05.tar.gz
4
viatorcomfr_2015-12-05.tar.gz
viatormfr_2015-12-05.tar.gz
viatorcomit_2015-12-05.tar.gz
viatormit_2015-12-05.tar.gz
viatorcomnl_2015-12-05.tar.gz
viatormnl_2015-12-05.tar.gz
5
viatorcomes_2015-12-05.tar.gz
viatormes_2015-12-05.tar.gz
viatorcombr_2015-12-05.tar.gz
viatormbr_2015-12-05.tar.gz
6
viatorcomde_2015-12-05.tar.gz
viatormde_2015-12-05.tar.gz
viatorcomdk_2015-12-05.tar.gz
viatorcomno_2015-12-05.tar.gz
viatorcomjp_2015-12-05.tar.gz
viatormjp_2015-12-05.tar.gz
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}