import re
regex = re.compile(r".*((de)|(dk)|(no)|(jp))_2015.+")
test_str = ("2\n\n"
"viatormobileprd_2015-12-05.tar.gz\n\n"
"3\n"
"viatorpartnerprd_2015-12-05.tar.gz\n"
"viatormpartnerprd_2015-12-05.tar.gz\n"
"viatorcomse_2015-12-05.tar.gz\n"
"viatormse_2015-12-05.tar.gz\n\n\n"
"4\n"
"viatorcomfr_2015-12-05.tar.gz\n"
"viatormfr_2015-12-05.tar.gz\n"
"viatorcomit_2015-12-05.tar.gz\n"
"viatormit_2015-12-05.tar.gz\n"
"viatorcomnl_2015-12-05.tar.gz\n"
"viatormnl_2015-12-05.tar.gz\n\n"
"5\n"
"viatorcomes_2015-12-05.tar.gz\n"
"viatormes_2015-12-05.tar.gz\n"
"viatorcombr_2015-12-05.tar.gz\n"
"viatormbr_2015-12-05.tar.gz\n\n"
"6\n"
"viatorcomde_2015-12-05.tar.gz\n"
"viatormde_2015-12-05.tar.gz\n"
"viatorcomdk_2015-12-05.tar.gz\n"
"viatorcomno_2015-12-05.tar.gz\n"
"viatorcomjp_2015-12-05.tar.gz\n"
"viatormjp_2015-12-05.tar.gz\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")