const regex = /.+?snuffs out the (\d+).. fire pit, and in seconds.+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?snuffs out the (\\d+).. fire pit, and in seconds.+', 'g')
const str = `\\#58FAACQaaron snuffs out the 1st fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 2nd fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 3rd fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 4th fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 5th fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 6th fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 7th fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 8th fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 9th fire pit, and in seconds the connecting bridge will also be extinguished!
\\#58FAACQaaron snuffs out the 10th fire pit, and in seconds the connecting bridge will also be extinguished!`;
const subst = `Bridge $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);