import Foundation
let pattern = #".+?snuffs out the (\d+).. fire pit, and in seconds.+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
\#58FAACQaaron snuffs out the 1st fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 2nd fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 3rd fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 4th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 5th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 6th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 7th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 8th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 9th fire pit, and in seconds the connecting bridge will also be extinguished!
\#58FAACQaaron snuffs out the 10th fire pit, and in seconds the connecting bridge will also be extinguished!
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Bridge $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)