#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[^|<>\\\/?"':*\s]+\/?)+)$"
Local $sString = "cat1/cat2/cat3" & @CRLF & _
"" & @CRLF & _
"cat1/cat2////cat3" & @CRLF & _
"cat1/cat 2/ cat3" & @CRLF & _
"cat1/cat 2/ /// a |<>"?\':*" & @CRLF & _
"cat1/cat2/|<>"?\':*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")