$re = '/^((?:[^|<>\\\\\/?"\':*\s]+\/?)+)$/m';
$str = 'cat1/cat2/cat3
cat1/cat2////cat3
cat1/cat 2/ cat3
cat1/cat 2/ /// a |<>"?\\\':*
cat1/cat2/|<>"?\\\':*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);