import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[^|<>\\\\\\/?\"':*\\s]+\\/?)+)$";
final String string = "cat1/cat2/cat3\n\n"
+ "cat1/cat2////cat3\n"
+ "cat1/cat 2/ cat3\n"
+ "cat1/cat 2/ /// a |<>\"?\\':*\n"
+ "cat1/cat2/|<>\"?\\':*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}