re = /^((?:[^|<>\\\/?"':*\s]+\/?)+)$/m
str = 'cat1/cat2/cat3
cat1/cat2////cat3
cat1/cat 2/ cat3
cat1/cat 2/ /// a |<>"?\\\':*
cat1/cat2/|<>"?\\\':*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end