#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^" & @CRLF & _
"(\d+ (" & @CRLF & _
" (\.\d+) |" & @CRLF & _
" (\(" & @CRLF & _
" \d+((\.\d+)? (,\d+((\.\d+)?))*" & @CRLF & _
" \))" & @CRLF & _
"))?)" & @CRLF & _
"" & @CRLF & _
"((,\d+ (" & @CRLF & _
" (\.\d+) |" & @CRLF & _
" (\(" & @CRLF & _
" \d+((\.\d+)? (,\d+((\.\d+)?))*" & @CRLF & _
" \))" & @CRLF & _
"))?)*)" & @CRLF & _
"$"
Local $sString = "2.5,1,5(2,3),1,2.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")