package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^
(\d+ (
(\.\d+) |
(\(
\d+((\.\d+)? (,\d+((\.\d+)?))*
\))
))?)
((,\d+ (
(\.\d+) |
(\(
\d+((\.\d+)? (,\d+((\.\d+)?))*
\))
))?)*)
$`)
var str = `2.5,1,5(2,3),1,2.5`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}