re = /^
(\d+ (
(\.\d+) |
(\(
\d+((\.\d+)? (,\d+((\.\d+)?))*
\))
))?)
((,\d+ (
(\.\d+) |
(\(
\d+((\.\d+)? (,\d+((\.\d+)?))*
\))
))?)*)
$/x
str = '2.5,1,5(2,3),1,2.5'
# Print the match result
str.match(re) do |match|
puts match.to_s
end