$re = '/^
(\d+ (
(\.\d+) |
(\(
\d+((\.\d+)? (,\d+((\.\d+)?))*
\))
))?)
((,\d+ (
(\.\d+) |
(\(
\d+((\.\d+)? (,\d+((\.\d+)?))*
\))
))?)*)
$/x';
$str = '2.5,1,5(2,3),1,2.5';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);