import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(\\+\\w+)";
final String string = "s = '(A) 2011-03-02 2011-03-01 Call Mom +project1 +project2'\n"
+ "re.findall('\\s(\\+.*?)', s)\n"
+ "# result ['+', '+']\n"
+ "re.findall('\\s(\\+project[0-9]*)', s2)\n"
+ "# result ['+project1', '+project2']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}