import re
regex = re.compile(r"\s(\+\w+)", flags=re.MULTILINE)
test_str = ("s = '(A) 2011-03-02 2011-03-01 Call Mom +project1 +project2'\n"
"re.findall('\\s(\\+.*?)', s)\n"
"# result ['+', '+']\n"
"re.findall('\\s(\\+project[0-9]*)', s2)\n"
"# result ['+project1', '+project2']")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")