re = /\s(\+\w+)/m
str = 's = \'(A) 2011-03-02 2011-03-01 Call Mom +project1 +project2\'
re.findall(\'\\s(\\+.*?)\', s)
# result [\'+\', \'+\']
re.findall(\'\\s(\\+project[0-9]*)\', s2)
# result [\'+project1\', \'+project2\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end