// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s(\+\w+)").unwrap();
let string = "s = '(A) 2011-03-02 2011-03-01 Call Mom +project1 +project2'
re.findall('\\s(\\+.*?)', s)
# result ['+', '+']
re.findall('\\s(\\+project[0-9]*)', s2)
# result ['+project1', '+project2']";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}