package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s*)(?:linear|radial)-gradient\s*\(((?:\([^\)]*\)|[^\)\(])*)\)`)
var str = `radial-gradient( circle farthest-corner, white)
radial-gradient( circle farthest-corner, white
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}