import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*)(?:linear|radial)-gradient\\s*\\(((?:\\([^\\)]*\\)|[^\\)\\(])*)\\)";
final String string = "radial-gradient( circle farthest-corner, white)\n"
+ "radial-gradient( circle farthest-corner, white\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}