$re = '/(?:\s*)(?:linear|radial)-gradient\s*\(((?:\([^\)]*\)|[^\)\(])*)\)/';
$str = 'radial-gradient( circle farthest-corner, white)
radial-gradient( circle farthest-corner, white
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);