re = /(?:\s*)(?:linear|radial)-gradient\s*\(((?:\([^\)]*\)|[^\)\(])*)\)/
str = 'radial-gradient( circle farthest-corner, white)
radial-gradient( circle farthest-corner, white
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end