#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Follow-up[\s\n\\n:]+([\d]{8,13})"
Local $sString = "Follow-up 614233222 Follow-up Please inlcude the below line in follow up tags where Follow-Up \n:123212323 567 Follow-Up 1234231234 which needs to be ignore with 123 <\n>Please include the line below in follow-up emails for this request.<\n><\n>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")