$re = '/Follow-up[\s\n\\\\n:]+([\d]{8,13})/i';
$str = 'Follow-up 614233222 Follow-up Please inlcude the below line in follow up tags where Follow-Up \\n:123212323 567 Follow-Up 1234231234 which needs to be ignore with 123 <\\n>Please include the line below in follow-up emails for this request.<\\n><\\n>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);