import Foundation
let pattern = #"Follow-up[\s\n\\n:]+([\d]{8,13})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Follow-up 614233222 Follow-up Please inlcude the below line in follow up tags where Follow-Up \n:123212323 567 Follow-Up 1234231234 which needs to be ignore with 123 <\n>Please include the line below in follow-up emails for this request.<\n><\n>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)