using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Follow-up[\s\n\\n:]+([\d]{8,13})";
string input = @"Follow-up 614233222 Follow-up Please inlcude the below line in follow up tags where Follow-Up \n:123212323 567 Follow-Up 1234231234 which needs to be ignore with 123 <\n>Please include the line below in follow-up emails for this request.<\n><\n>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}