#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\d\s)\d{5,}(?=\s\d)"
Local $sString = "234 24567 3452345 dasda 5345234 fdasdg asdf 24567 3452345 35345 24567 sfdfsd 452345354 23452345345 3245234523" & @CRLF & _
"" & @CRLF & _
"Lorem Ipsum is simply dummy 345 text of the printing and34 3456778 45typesetting industry. Lorem 2345677 Ipsum has been the 34 34567 34 industry's standard dummy text ever since 2342 341234 4234the 1500s" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")