re = /(?<=\d\s)\d{5,}(?=\s\d)/
str = '234 24567 3452345 dasda 5345234 fdasdg asdf 24567 3452345 35345 24567 sfdfsd 452345354 23452345345 3245234523
Lorem Ipsum is simply dummy 345 text of the printing and34 3456778 45typesetting industry. Lorem 2345677 Ipsum has been the 34 34567 34 industry\'s standard dummy text ever since 2342 341234 4234the 1500s
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end