use strict;
my $str = '234 24567 3452345 dasda 5345234 fdasdg asdf 24567 3452345 35345 24567 sfdfsd 452345354 23452345345 3245234523
Lorem Ipsum is simply dummy 345 text of the printing and34 3456778 45typesetting industry. Lorem 2345677 Ipsum has been the 34 34567 34 industry\'s standard dummy text ever since 2342 341234 4234the 1500s
';
my $regex = qr/(?<=\d\s)\d{5,}(?=\s\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}