const regex = /(?<=\d\s)\d{5,}(?=\s\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d\\s)\\d{5,}(?=\\s\\d)', 'g')
const str = `234 24567 3452345 dasda 5345234 fdasdg asdf 24567 3452345 35345 24567 sfdfsd 452345354 23452345345 3245234523
Lorem Ipsum is simply dummy 345 text of the printing and34 3456778 45typesetting industry. Lorem 2345677 Ipsum has been the 34 34567 34 industry's standard dummy text ever since 2342 341234 4234the 1500s
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}