#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?U)MyClass\.g\(\"(.*)\".*"
Local $sString = "MyClass.g("this is sparta" );" & @CRLF & _
"MyClass.g("toto" );" & @CRLF & _
"MyClass.g("My super parameter is {0}" );" & @CRLF & _
"MyClass.g("this is sparta", some code);" & @CRLF & _
"MyClass.g("this main should work", MyClass.g("test" ));" & @CRLF & _
"Debug.Log(MyClass.g("this is a test" ));"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)