import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "MyClass\\.g\\(\\\"(.*)\\\".*";
final String string = "MyClass.g(\"this is sparta\" );\n"
+ "MyClass.g(\"toto\" );\n"
+ "MyClass.g(\"My super parameter is {0}\" );\n"
+ "MyClass.g(\"this is sparta\", some code);\n"
+ "MyClass.g(\"this main should work\", MyClass.g(\"test\" ));\n"
+ "Debug.Log(MyClass.g(\"this is a test\" ));";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}