package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)MyClass\.g\(\"(.*)\".*`)
var str = `MyClass.g("this is sparta" );
MyClass.g("toto" );
MyClass.g("My super parameter is {0}" );
MyClass.g("this is sparta", some code);
MyClass.g("this main should work", MyClass.g("test" ));
Debug.Log(MyClass.g("this is a test" ));`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}