using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MyClass\.g\(\""(.*)\"".*";
string substitution = @"$1";
string input = @"MyClass.g(""this is sparta"" );
MyClass.g(""toto"" );
MyClass.g(""My super parameter is {0}"" );
MyClass.g(""this is sparta"", some code);
MyClass.g(""this main should work"", MyClass.g(""test"" ));
Debug.Log(MyClass.g(""this is a test"" ));";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}