package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(\s*)(\d+)?(\.\d+)?(\s*)(?i:years|year|yrs|y|months|month|m)?(\s*)(/)?(\s*)(\d+)?(\.\d+)?(\s*)(?i:years|year|yrs|y|months|month|m)?(\s*)(-)?(\s*)(\d+)(\.\d+)?(\s*)?(?i:years|year|yrs|y|months|month|m)`)
var str = `1.5Year
1.6years
1.7y
123.2h
23.4CM
2Mw
3wm
01Y
1-2y
39/3-4y
39-34yrs
3.5 - 4.5y
4.6 / 4.5 - 6.5y
9.5-10.5yEAR
7-7.5Y
2m-3y
7 m-7.5 Y
7m - 8.5y
7 m - 8 y
7.5 m -8.5 y
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}