# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\s*)(\d+)?(\.\d+)?(\s*)(?i:years|year|yrs|y|months|month|m)?(\s*)(/)?(\s*)(\d+)?(\.\d+)?(\s*)(?i:years|year|yrs|y|months|month|m)?(\s*)(-)?(\s*)(\d+)(\.\d+)?(\s*)?(?i:years|year|yrs|y|months|month|m)"
test_str = ("1.5Year\n"
"1.6years\n"
"1.7y\n"
"123.2h\n"
"23.4CM\n"
"2Mw\n"
"3wm\n"
"01Y\n"
"1-2y\n"
"39/3-4y\n"
"39-34yrs\n"
"3.5 - 4.5y\n"
"4.6 / 4.5 - 6.5y\n"
"9.5-10.5yEAR\n"
"7-7.5Y\n"
"2m-3y\n"
"7 m-7.5 Y\n"
"7m - 8.5y\n"
"7 m - 8 y\n"
"7.5 m -8.5 y\n\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.